Wolfgang Jeltsch wrote:
>Am Freitag, 17. Februar 2006 11:16 schrieb Michael Hanus:
>
>>>>One other mini-proposal: I like to include the definition
>>>>
>>>>x_ = let x free in x
>>>>
>>>But because it's so obscure, it shouldn't be used, in my opinion.
>>>
>>I mean the name is obscure for meaningful functions
>>or pattern variables so that it is not used in existing programs.
>>However, the name x_ is reasonable to denote an anonymous free
>>variable. Or any better suggestion for a compact name?
>>
>
>I would never name a global variable x or something similar. In fact, I also
>don't name any local variables x. I'm very much in favor of descriptive
>names like "free" (which is a reserved word, unfortunately).
>
I agree. Such a function should be named free_ instead of x_.
What I do not like is the difference between:
main = let free_ free in (free_,free_)
and
free_ = let x free in x
main = (free_,free_)
having local constants but only global functions will be confusing for
programmers. However, this is a general problem of Curry's design.
Regards,
Frank
_______________________________________________
curry mailing list
curry_at_lists.RWTH-Aachen.DE
http://MailMan.RWTH-Aachen.DE/mailman/listinfo/curry
Received on Fr Feb 17 2006 - 17:47:01 CET